Adam's Lair Forum

game development and casual madness
It is currently 2017/03/26, 11:19

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: 2017/01/05, 13:52 
Junior Member
Junior Member

Joined: 2016/03/09, 12:20
Posts: 26
Role: Hobbyist
Hi!

I have created map with tileset plugin based on tutorial that is avail. on wiki. My spritesheet have 8x8 tiles without borders. I set filters to nearest and turned off antialiasing. Still I have those black lines between tiles. I get this in scene editor and in game view.

Wanted to use parallax camera and have ability to zoom in and out... but so far I get this problem away if I set it to flat and set FocusDist to: POW * 500. I saw old thread when there was something about making spritesheet with borders, but wanted to write here before I change my whole spritesheet. LINK: viewtopic.php?f=16&t=191


Top
 Profile  
 
PostPosted: 2017/01/05, 14:29 
Forum Adept
Forum Adept
User avatar

Joined: 2015/03/15, 02:49
Posts: 351
Location: Out there
Role: Hobbyist
Maybe the tile size might be off, wether in your map or in the spritesheet?
I use the tile pluging immensely, and haven't been able to see that.

Post some pictures of the editor, please.

_________________
Hello there! Nice to meet you!
I have github. Apologies in advance for bad coding practices.


Top
 Profile  
 
PostPosted: 2017/01/05, 19:01 
Junior Member
Junior Member

Joined: 2016/03/09, 12:20
Posts: 26
Role: Hobbyist
Hi, thanks for trying to help, was at work so I couldn't link any pictures.

I have 8x8 in map and tileset.

Spritesheet:

Image

Screenshots from editor: (both are for flat perspective)
Notice line slicing terrain in half in the first image.

Image

Image

Edit: And the texture itself that is linked to the tileset

Image


Top
 Profile  
 
PostPosted: 2017/01/05, 20:41 
Site Admin
Site Admin
User avatar

Joined: 2013/05/11, 22:30
Posts: 1933
Location: Germany
Role: Professional
Hey there!

The texture settings look good, but they aren't actually used when you do tilemaps: A Tileset will create its own internal texture based on the pixmap* and the settings you really want to adjust are the ones in the Tileset editor when you select the visual layer that you're displaying here.

* The reason why it's done this way is because the Tileset might decide to rearrange some tiles or generate a few more for performance reasons.

Can you show us a screenshot of those settings?

_________________
Blog | GitHub | Twitter (@Adams_Lair)


Top
 Profile  
 
PostPosted: 2017/01/05, 21:02 
Junior Member
Junior Member

Joined: 2016/03/09, 12:20
Posts: 26
Role: Hobbyist
Ah, that explains.
Sure, here is screenshot:

Image

Every other layer have same settings.


Top
 Profile  
 
PostPosted: 2017/01/05, 21:20 
Site Admin
Site Admin
User avatar

Joined: 2013/05/11, 22:30
Posts: 1933
Location: Germany
Role: Professional
Set TargetTileMargin to 1. This will make sure every till will get a border of its own color around itself in the internal texture, so filtering and mipmapping artifacts are prevented. Even if you disable texture filtering, you might still get a little bit due to fullscreen antialiasing / multisampling.

here is how it should look like with the proper margin:

Image
Image

_________________
Blog | GitHub | Twitter (@Adams_Lair)


Top
 Profile  
 
PostPosted: 2017/01/05, 22:08 
Junior Member
Junior Member

Joined: 2016/03/09, 12:20
Posts: 26
Role: Hobbyist
Yeah, that did the trick. Looking good now. Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group