Adam's Lair Forum

game development and casual madness
It is currently 2017/09/23, 22:02

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Editor unable to launch
PostPosted: 2017/07/12, 03:36 
Newbie
Newbie

Joined: 2017/07/12, 03:26
Posts: 2
Role: Observer
my duality editor failed to launch

when I start the duality editor it gives me the prompter with the progress thing and then it showed me the dualitor text and after that it seemed to launch and then it closed again, I thought I have to wait but after 3 hours, nothing show up.

I'm using a 32 bit windows 10.

is there a requirement that I don't have?


Last edited by rifqiaufa on 2017/07/13, 03:16, edited 2 times in total.

Top
 Profile  
 
PostPosted: 2017/07/12, 12:59 
Forum Addict
Forum Addict
User avatar

Joined: 2013/09/19, 14:31
Posts: 847
Location: Italy
Role: Hobbyist
Hi, and welcome to the forum! :mrgreen:

rifqiaufa wrote:
my duality editor failed to launch

when I start the duality editor it gives me the prompter with the progress thing and then it showed me the dualitor text and after that it seemed to launch and then it closed again, I thought I have to wait but after 3 hours, nothing show up.

I'm using a 32 bit windows 10.

is there a requirement that I don't have?


Do you have a logfile_editor.txt file in your Duality folder? if yes, can you upload it somewhere?

_________________
Come on Duality's Discord channel. It's entertaining and productive! :mrgreen:


Top
 Profile  
 
PostPosted: 2017/07/13, 03:18 
Newbie
Newbie

Joined: 2017/07/12, 03:26
Posts: 2
Role: Observer
SirePi wrote:
Hi, and welcome to the forum! :mrgreen:

rifqiaufa wrote:
my duality editor failed to launch

when I start the duality editor it gives me the prompter with the progress thing and then it showed me the dualitor text and after that it seemed to launch and then it closed again, I thought I have to wait but after 3 hours, nothing show up.

I'm using a 32 bit windows 10.

is there a requirement that I don't have?


Do you have a logfile_editor.txt file in your Duality folder? if yes, can you upload it somewhere?


here

Quote:
[Core] Msg: Using 'DefaultPluginLoader' to load plugins.
[Core] Msg: Environment Info:
Current Directory: C:\Users\Rifqi 2\Desktop\Duality
Command Line: "C:\Users\Rifqi 2\Desktop\Duality\DualityEditor.exe"
Operating System: Microsoft Windows NT 6.2.9200.0 (Windows 8)
64 Bit OS: False
64 Bit Process: False
CLR Version: 4.0.30319.42000
Processor Count: 2
[Core] Msg: Currently Loaded Assemblies:
mscorlib 4.0.0.0
DualityEditor 2.9.1.0
System.Windows.Forms 4.0.0.0
System 4.0.0.0
System.Drawing 4.0.0.0
Duality 2.12.9.0
System.Runtime 4.0.0.0
System.IO 4.0.0.0
System.Collections 4.0.0.0
NuGet.Core 2.8.50926.602
System.Core 4.0.0.0
System.Xml.Linq 4.0.0.0
System.Xml 4.0.0.0
System.Xml.XDocument 4.0.0.0
System.Reflection 4.0.0.0
System.Xml.ReaderWriter 4.0.0.0
WindowsBase 4.0.0.0
System.Configuration 4.0.0.0
System.ComponentModel.DataAnnotations 4.0.0.0
AdamsLair.WinForms 1.1.12.0
WeifenLuo.WinFormsUI.Docking 2.8.1.0
DualityPrimitives 2.0.4.0
System.Runtime.Extensions 4.0.0.0
System.Threading 4.0.0.0
System.Diagnostics.Debug 4.0.0.0
System.Linq 4.0.0.0
System.Globalization 4.0.0.0
[Core] Msg: Plugin Base Directories:
Plugins
[Core] Msg: Available Assembly Paths:
Plugins\CamView.editor.dll
Plugins\Compatibility.core.dll
Plugins\DefaultOpenTKBackend.core.dll
Plugins\DefaultOpenTKBackend.editor.dll
Plugins\DotNetFrameworkBackend.core.dll
Plugins\EditorBase.editor.dll
Plugins\HelpAdvisor.editor.dll
Plugins\LogView.editor.dll
Plugins\ObjectInspector.editor.dll
Plugins\OpenALSoft32.dll
Plugins\OpenALSoft64.dll
Plugins\PackageManagerFrontend.editor.dll
Plugins\ProjectView.editor.dll
Plugins\SceneView.editor.dll
[Core] Msg: Scanning for core plugins...
[Core] Msg: Plugins\Compatibility.core.dll...
[Core] Msg: Assembly loaded: Compatibility.core 2.0.2.0
[Core] Msg: Assembly loaded: System.Linq.Expressions 4.0.0.0
[Core] Msg: Assembly loaded: Anonymously Hosted DynamicMethods Assembly 0.0.0.0
[Core] Msg: Plugins\DefaultOpenTKBackend.core.dll...
[Core] Msg: Assembly loaded: DefaultOpenTKBackend.core 2.0.19.0
[Core] Msg: Assembly loaded: OpenTK 1.1.8.0
[Core] Msg: Plugins\DotNetFrameworkBackend.core.dll...
[Core] Msg: Assembly loaded: DotNetFrameworkBackend.core 2.1.1.0
[Core] Msg: Loading auxiliary libraries...
[Core] Msg: Initializing ISystemBackend...
[Core] Msg: Assembly loaded: System.Text.RegularExpressions 4.0.0.0
[Core] Msg: .Net Framework...
[Core] Msg: Initializing IGraphicsBackend...
[Core] Msg: OpenGL 2.1 (OpenTK)...
[Core] Msg: Initializing OpenTK...
[Core] Msg: Platform Backend: PreferNative
EnableHighResolution: False
[Core] Msg: Available display devices:
[Core] Msg: First : 1280x 800 at 50 Hz, 32 bpp, pos [ 0, 0] (Primary)
[Core] Msg: Initializing IAudioBackend...
[Core] Msg: OpenAL (OpenTK)...
[Core] Msg: OpenAL Drivers not found. Using 32 Bit software fallback.
[Core] Msg: Available devices:
Headphones (High Definition Audio Device) (Default)
Headphones (High Definition Audio Device) (Default)
[Core] Msg: Current device: OpenAL Soft
[Core] Msg: OpenAL Version: 1.1 ALSOFT 1.15.1
Vendor: OpenAL Community
Renderer: OpenAL Soft
Effects: True
[Core] Msg: 256 sources available
[Core] Msg: Initializing core plugins...
[Core] Msg: Compatibility.core...
[Edit] Msg: Analyzing Core Plugin: Compatibility.core
[Core] Msg: DefaultOpenTKBackend.core...
[Edit] Msg: Analyzing Core Plugin: DefaultOpenTKBackend.core
[Core] Msg: DotNetFrameworkBackend.core...
[Edit] Msg: Analyzing Core Plugin: DotNetFrameworkBackend.core
[Core] Msg: DualityApp initialized
Debug Mode: False
Command line arguments: null
[Edit] Msg: Scanning for editor plugins...
[Edit] Msg: Plugins\CamView.editor.dll...
[Core] Msg: Assembly loaded: CamView.editor 2.5.1.0
[Edit] Msg: Plugins\DefaultOpenTKBackend.editor.dll...
[Core] Msg: Assembly loaded: DefaultOpenTKBackend.editor 2.0.5.0
[Edit] Msg: Plugins\EditorBase.editor.dll...
[Core] Msg: Assembly loaded: EditorBase.editor 2.2.7.0
[Core] Msg: Assembly loaded: PopupControl 1.0.0.0
[Edit] Msg: Plugins\HelpAdvisor.editor.dll...
[Core] Msg: Assembly loaded: HelpAdvisor.editor 2.0.4.0
[Edit] Msg: Plugins\LogView.editor.dll...
[Core] Msg: Assembly loaded: LogView.editor 2.1.8.0
[Edit] Msg: Plugins\ObjectInspector.editor.dll...
[Core] Msg: Assembly loaded: ObjectInspector.editor 2.0.5.0
[Edit] Msg: Plugins\PackageManagerFrontend.editor.dll...
[Core] Msg: Assembly loaded: PackageManagerFrontend.editor 2.1.1.0
[Core] Msg: Assembly loaded: Aga.Controls 1.7.6.0
[Edit] Msg: Plugins\ProjectView.editor.dll...
[Core] Msg: Assembly loaded: ProjectView.editor 2.0.11.0
[Edit] Msg: Plugins\SceneView.editor.dll...
[Core] Msg: Assembly loaded: SceneView.editor 2.0.12.0
[Core] Msg: Initializing IEditorGraphicsBackend...
[Core] Msg: GLControl (OpenTK)...
[Core] Msg: Assembly loaded: OpenTK.GLControl 1.1.8.0
[Core] Msg: Initializing default content...
[Core] Msg: Assembly loaded: System.Runtime.InteropServices 4.0.0.0
[Core] Msg: Assembly loaded: System.Reflection.Extensions 4.0.0.0
[Core] Msg: Assembly loaded: System.Collections.Concurrent 4.0.0.0
[Core] Msg: Assembly loaded: System.Threading.Tasks.Parallel 4.0.0.0
[Core] Msg: Assembly loaded: System.Text.Encoding 4.0.0.0
[Core] Msg: Assembly loaded: NVorbis 0.7.5.0
[Core] Msg: ...done!
[Edit] Msg: Loading user data...
[Edit] Msg: Loading DockPanel data...
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.CamView.CamView'
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.ProjectView.ProjectFolderView'
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.SceneView.SceneView'
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.ObjectInspector.ObjectInspector'
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.HelpAdvisor.HelpAdvisor'
[Edit] Msg: Deserializing layout: 'Duality.Editor.Plugins.LogView.LogView'
[Edit] Msg: Loading editor user data...
[Edit] Msg: Initializing editor plugins...
[Edit] Msg: CamView.editor...
[Edit] Msg: DefaultOpenTKBackend.editor...
[Edit] Msg: EditorBase.editor...
[Edit] Msg: HelpAdvisor.editor...
[Edit] Msg: LogView.editor...
[Edit] Msg: ObjectInspector.editor...
[Edit] Msg: PackageManagerFrontend.editor...
[Edit] Msg: ProjectView.editor...
[Edit] Msg: SceneView.editor...
[Core] Msg: Assembly loaded: FarseerDuality 4.1.4.0


Top
 Profile  
 
PostPosted: 2017/07/13, 18:30 
Site Admin
Site Admin
User avatar

Joined: 2013/05/11, 22:30
Posts: 2012
Location: Germany
Role: Professional
Hey there and welcome!

Thanks for the logfile! Seems to be the right one, but unfortunately, nothing in there really rings a bell. No errors and no logged incompatibilities.

Can you run DualityLauncher.exe instead of the editor, and what happens if you do that?

When you run the editor and it doesn't show up, is there a DualityEditor.exe process running in the background that just doesn't show a window? If there is in fact a process running, can you attach Visual Studio to it, hit Pause and see if there's a callstack?

PS: I split this up into a new topic, as it is definitely a different issue than the one this was originally posted in. Let's keep this separate so others who come searching have an easier time figuring out what's up :)

_________________
Blog | GitHub | Twitter (@Adams_Lair)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group