Adam's Lair Forum

game development and casual madness
It is currently 2019/11/20, 21:18

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 2015/11/13, 21:09 
Newbie
Newbie

Joined: 2015/11/13, 21:01
Posts: 7
Role: Professional
Hi!

I've just downloaded Duality from
Code:
http://dualitybin.adamslair.net/
(snap! can't use real links in my first post...), and ran the exe. It downloaded a few packages, nice and dandy. But running DualityEditor.exe does nothing.

Here is a logfile.txt:
Code:
http://pastebin.com/9upsSErx


logfile_editor.txt is empty (0 bytes)

Running DualityLauncher.exe starts a blank black window and nothing happens.

Any ideas what's cracking? :)

(I'm on Windows 10, latest updates.)


Top
 Profile  
 
PostPosted: 2015/11/13, 21:23 
Member
Member
User avatar

Joined: 2015/10/29, 18:52
Posts: 69
Location: Finland
Role: Hobbyist
I think the "prebuilt" DualityLauncher.exe has no data. It is copy-pasted to your project's folder when you publish it. Without content, it's just a blank window? No idea what's up though, but you might wanna check if you have the pre-reqs installed!

_________________
.
..
...
....
What?


Top
 Profile  
 
PostPosted: 2015/11/13, 21:39 
Site Admin
Site Admin
User avatar

Joined: 2013/05/11, 22:30
Posts: 2073
Location: Germany
Role: Professional
misthema wrote:
I think the "prebuilt" DualityLauncher.exe has no data. It is copy-pasted to your project's folder when you publish it. Without content, it's just a blank window

Yup, the blank window when running the launcher is perfectly normal. It displays your game - which is empty by default. Nothing wrong here.

However:
Quote:
But running DualityEditor.exe does nothing.

This of course shouldn't happen. With an empty editor log, it's hard to tell what is happening though.. :troubled: I'm going to need some more info on this. Can you explain exactly what happens when you perform a fresh install of Duality?

What you should see:

  • License acceptance dialog.
  • A progress bar with packages downloading.
  • The progress bar closes itself and runs a console window, which writes some logs about how it copies files around. That's the updater applying the update operations after downloading packages.
  • The console should close itself and then run the editor again. You should see a splash screen.
  • The editor opens.

Can you confirm this? Where does it seem to break? What do you see instead? Also, it would be very helpful to examine your complete folder structure after the update was applied. The whole Duality folder will likely a bit too big to upload it somewhere, but can you take a screenshot of the root contents as well as the Source\Packages folder contents?

_________________
Blog | GitHub | Twitter (@Adams_Lair)


Top
 Profile  
 
PostPosted: 2015/11/13, 22:56 
Newbie
Newbie

Joined: 2015/11/13, 21:01
Posts: 7
Role: Professional
All goes as you describe it, Adam, but I see no splashscreen, and nothing shows up.

I shot a video of it all: https://www.youtube.com/watch?v=ByOyPFQY-3k

And, here's the editor log: http://pastebin.com/YPL7sPWn

It's there on the first run.


Top
 Profile  
 
PostPosted: 2015/11/14, 00:18 
Forum Adept
Forum Adept

Joined: 2015/07/08, 16:41
Posts: 414
Role: Gamer
Hmm, this is very strange indeed. Can you post what version of the .NET Framework you have installed? You need at least .NET Framework 4.5 installed (I think).

By the way, the last file copied in the package update seems to be Nuget.Core.dll.

Also, in the first log file, the audio backend does not find the OpenAL drivers and resorts to a fallback. This is a launcher log, though. Could this cause any problems with the editor, too? I'm sure you guys already saw that part though...

EDIT: Try running it again, this time with administrator capabilities. Though this is very, very unlikely to be a factor. Also, does the editor's process appear in the task manager?


Top
 Profile  
 
PostPosted: 2015/11/14, 00:58 
Forum Adept
Forum Adept
User avatar

Joined: 2015/03/15, 02:49
Posts: 354
Location: Out there
Role: Hobbyist
And what about system specs? Mainly graphics card.

_________________
Hello there! Nice to meet you!
I have github. Apologies in advance for bad coding practices.


Top
 Profile  
 
PostPosted: 2015/11/14, 01:49 
Site Admin
Site Admin
User avatar

Joined: 2013/05/11, 22:30
Posts: 2073
Location: Germany
Role: Professional
hsnabn wrote:
Hmm, this is very strange indeed. Can you post what version of the .NET Framework you have installed? You need at least .NET Framework 4.5 installed (I think).


In the log file it says CLR version 4.0.30319.42000, which should be fine. Not entirely sure if we can derive .Net 4.5 being installed, but I'd probably look at other problem sources first.

hsnabn wrote:
Also, in the first log file, the audio backend does not find the OpenAL drivers and resorts to a fallback. This is a launcher log, though.


That's perfectly fine. If there are no OpenAL drivers, Duality puts a software fallback in place, and even if that fails, there'd just be no audio. Nice catch though ^^

eyeliner wrote:
And what about system specs? Mainly graphics card.

Good thought - we've had that common problem a few times. Checked the logfile from the launcher, and it states the following:
Code:
[Core] Msg:   OpenGL Version: 4.5.0 NVIDIA 353.62
              Vendor: NVIDIA Corporation
              Renderer: GeForce GTX 960/PCIe/SSE2
              Shading Language Version: 4.50 NVIDIA

Looks good, modern enough.

So.. with all these potential problem causes out of the way (except for the .Net 4.5 one, which probably should be double-checked), this becomes a bit trickier. :troubled:

Zajkonur wrote:

Thanks! Especially for the video :) There's a strong visual hint in your file manager: No Data directory. It usually gets auto-generated on the first startup, but apparently it fails here. Which puts this here:

Quote:
EDIT: Try running it again, this time with administrator capabilities.


...into a slightly more probable light - maybe the UAC is blocking file access somehow because the editor tries to create a hidden desktop.ini in the Data folder to apply the special icon? It sounds.. a bit strange, but trying can't hurt. When you run it as administrator, make sure to do so after the installation, as I'm not sure admin mode will survive the auto-restart.

If that still doesn't help, I've got only one idea left: Can you download the latest source code version and compile Duality yourself? Make sure to use "Build Solution" to build everything. When you run the DualityEditor project in debug mode after the build has finished, what happens? Is there an exception or similar?

_________________
Blog | GitHub | Twitter (@Adams_Lair)


Top
 Profile  
 
PostPosted: 2015/11/14, 14:38 
Newbie
Newbie

Joined: 2015/11/13, 21:01
Posts: 7
Role: Professional
I now tried to install Duality at home, on Windows 7 Home Premium. BitDefender anti-virus blocked the process DualityUpdater.exe due to "suspicious activity". I terminated BitDefender, tried installing again, but this time, it behaves the same as in work on Windows 10. Simply nothing happens. I'll try to build it myself then. :)


Top
 Profile  
 
PostPosted: 2015/11/14, 17:25 
Newbie
Newbie

Joined: 2015/11/13, 21:01
Posts: 7
Role: Professional
When I build the solution, the editor works. :) I'm just unsure how to use it properly now. Should I copy the Debug folder somewhere and use it as if it worked normally? I'm sure there are more files than there would be now.

Can you guys install it without any problems? It's weird that both machines with different OS have a problem installing it.


Top
 Profile  
 
PostPosted: 2015/11/14, 17:49 
Newbie
Newbie

Joined: 2015/11/13, 21:01
Posts: 7
Role: Professional
On Win 7, the editor at least crashes with a message, dumping three files. Two are text files. If it's any help, see them here: http://pastebin.com/siLfYNdC

The third is a large dump file (*.mdmp).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group